Remove JavaLoader to support Java 11

Description

JavaLoader must be removed from Core to be able to move forward with Java 11, existing uses of JavaLoader should now use Core's JAR loading by convention feature (FC-3180)

Environment

None

Status

Assignee

Unassigned

Reporter

Justin Carter

Labels

None

Fix versions

Priority

Major
Configure